
A l'occasion de la version 0.6  

un nouveau site internet est maintenant à votre disposition : 

 

www.louzone.com 

 

Venez jeter un coup d'oeil ... de temps en temps ... 

 

 

Introduction 

 
Loutext permet de créer des textures, à savoir un dessin qui peut se juxtaposer à lui-même sans 
qu’aucune “rupture” ne soit visible. 
 
Chaque mois (c’est juste un souhait …), une nouvelle version sera disponible. Ces nouvelles 
versions peuvent être enrichies grâce à vos remarques et idées. 
 
Si vous avez besoin d’aide, si vous avez des idées d’améliorations ou des remarques à faire, 
n’hésitez pas à m’envoyer un email : 
 
luc.helie@wanadoo.fr 
 
LouText 0.6 est un Freeware dont les textures peuvent être utilisées librement en dehors de 
toute utilisation commerciale. 
 

 

Nouveautés Version 0.6 (Octobre 2004) 
 

Formes de paramètres 
 

Certains modules ont beaucoup de paramètres. Il était donc intéressant de pouvoir 
sauvegarder un ensemble de paramètres au niveau module. C'est chose faite pour 
certains modules avec la version 0.6. 
Ces modules disposent maintenant de 3 boutons permettant la génération aléatoire des 
paramètres ainsi que la sauvegarde et la restauration des paramètres du module. 
 
L'extension du fichier où ces paramètres sont sauvegardés est .mpr. 



 

Une nouvelle façon de mélanger la "couche courante" et la "couche résultat" 
 
Les scrollbars “Result Layer” et “Current Layer” du panneau "Result and current layers weight" 
définissent le poids de ces 2 couches. Lorsque ces 2 valeurs sont à 0 le "Blending mask" est 
utilisé. 
 
Il existe maintenant un bouton "Use blending mask" qui permet d'initialiser les 2 valeurs à 0. 
 
Le "blending mask" permet d'élargir considérablement les possibilités de mélange entre la 
couche courante et la couche résultat. Au lieu d'avoir un poids unique pour chaque pixel, le 
"blending mask" donne un poids différent à chacun des pixels. 
 
Pour utiliser le "Blending mask" il faut en principe suivre les étapes suivantes : 

 
- Commencer par créer une texture à base de un ou plusieurs modules 
- Puis, ajouter le module "Channels > Move to blending mask". Ce module permet de 
transférer l'un des canaux de la texture dans une zone de sauvegarde du "Blending Mask". 
- Ajouter ensuite quelques modules pour créer une "vraie" texture. Normalement, le 
premier de ces modules aura les 3 paramètres de mélanges à la valeur "Current Layer" 
pour éviter tout mélange avec la texture précédente qui aura servi de "Blending Mask". 
Ces modules peuvent maintenant reposer sur le "Blending Mask" pour effectuer le 
mélange. 

 

Nouveaux modules 
 

• Textures > Nature > Inside the body 
Ressemble à une échographie ??? 
 

• Filters > Blur 
Ce module permet de flouter la texture. Il repose sur 2 algorithmes ayant chacun 2 
formes possibles (Carrée et circulaire) 
 

• Effects > Auto Color 
Ce module "améliore" une texture un peu "plate". Utilisez-le pour en comprendre l'effet 
... 
 

• Effects > Offset Effects > Pack 2 
Ce nouveau module "Offset Effects" est basé sur 53 nouveaux algorithmes qui disposent 
de 3 paramètres pour chacun des canaux. Chaque paramètre dispose de 2 valeurs. Ce 
qui implique un nombre de combinaisons assez important : 
 
53 * 2 * 2 * 2 * 2 * 2 * 2 * 2 * 2 * 2 => 27.136 combinaisons. Même si certaines 
d'entre elles sont assez semblables cela donne un bon nombre de possibilités ... 
 
Etant donné que les décalages en largeur et en hauteur peuvent varier de -20 à + 20 (41 
valeurs) cela donne 27.136 * 41 * 41 (45.615.616) résultats possibles et différents...  

 



Remarques générales 
 

 

Définition des couleurs 
 
Il existe en informatique différents moyens d’exprimer une couleur. LouText utilise deux d’entres 
eux : le mode RGB et le mode HSL.  
 
Le mode RGB consiste à “ mélanger ” du rouge (Red), du vert (Green) et du bleu (Blue) pour 
obtenir une couleur. La quantité de chacune de ces couleurs peut varier de 0 à 255. 
 
Le mode HSL définit une couleur pas sa teinte (Hue), sa saturation et sa luminosité. La teinte 
peut varier de 0 à 359, la saturation de 0 à 255 et la luminosité de 0 à 255. 
 

Utilisation des modes RGB et HSL 
 

Vous pouvez mélanger dans LouText des modules utilisant le mode RGB à des modules utilisant 
le mode HSL. Module après module LouText conserve l’état de votre texture en RGB et en HSL. 
Cela étant, la conversion d’une couleur du mode HSL au mode RGB puis au mode HSL ne 
garantit pas le retour aux valeurs d’origine. 

 



La forme principale 
 

 

La forme principale est constituée d’un menu et d’un espace de travail destiné aux formes 
“Image”. Les formes “Image” vous permettent de visualiser le résultat du calcul d’une texture. 
Vous pouvez créer plusieurs formes “Image” (Image>New), la forme active sera utilisée pour 
l’affichage de la texture courante. 

 
Le menu de la forme principale 

 
Image  
 

New Permet la création d’une nouvelle forme “Image” d’une taille 
quelconque et limitée à 1024 x 1024 pixels. 

 
Save Sauvegarde l’image active dans un fichier au format bmp. 
 
BMP Format Permet de choisir une profondeur de couleur entre 8, 16, 24 et 32 

bits. 
 

Texture 
 

New Ouvre la forme “Texture” et crée une nouvelle texture. 
 
Load Charge une texture à partir d’un fichier de texture (extension .lou) 

et ouvre la forme “Texture” 
 

Save Enregistre la texture courante dans un fichier de texture (extension 
.lou) 

 
Help 
 

English L’aide des modules est en anglais. 
 
Français L’aide des modules est en français. 



La forme “Texture” 
 

La forme “Texture” permet de définir une texture par la combinaison de “modules” (200 
maximum). La forme “Texture” est composée d’un menu et de 3 panneaux de paramètres : 
"Modules", "Current module blending parameters", et "Randomize all modules and Process".  
 
Le panneau “Modules”, au départ vide, est constitué de la liste des modules que vous avez 
ajouté à votre texture. Ils seront traités de haut en bas pour créer une texture. 
 
Tous les modules comme le module “Perlin Noise” ou le module “Chaotic functions” qui ne 
produisent pas de textures juxtaposables apparaîtront en rouge dans la liste des modules. 
 
Le module courant est identifié par une pastille beige dans la seconde colonne. Pour se déplacer 
d’un module à un autre il suffit de cliquer sur le nom du module. 
 
Le panneau "Current module blending parameters" définit comment la couche courante et la 
couche résultat seront mélangées. (La définition de la couche courante et la couche résultat se 
trouve dans le fichier FAQ.) 
 
Les paramètres de mélanges ne sont disponibles que pour les modules de type"Textures" ou 
"Functions" . Bien sur, le premier module de la liste ne dispose pas de paramètres de mélange. 
 
Le panneau "Randomize all modules and Process" permet de générer des paramètres aléatoires 
de mélange. 
 
 
 
 
En dessous du panneau “ Blending ” vous disposez de 5 boutons : 

 
Process   

Calcul de la texture du premier module jusqu’au module courant 

Fleche Haute/ Fleche Basse  
Déplace le module courant vers le haut ou vers le bas  

Activ  
Définit si le module courant est actif 

Remove   
Détruit le module courant 



 
Le menu de la forme “Texture” 

 
Les menus "Texture", "Functions", "Filters", "Effects", "Adjust", "Geometric", "Buffers" et 
"Channels"  permettent d’ajouter de nouveaux modules à la liste. Le menu “Color 
Channels” définit le canal (HSL or RGB) qui sera affiché dans la forme “Image”. 
 
Dès qu’un module est choisi dans l’un des menus, le nom de celui-ci apparaît dans le 
panneau “Modules”. En même temps, une grille de saisie des paramètres est affichée. 
Vous pouvez à ce moment modifier les paramètres du module ou bien le faire plus tard en 
cliquant sur son nom dans la liste des modules. Seule la grille de paramètres du module 
courant est affichée. 
 
Remarque : La fonction “Buffers>Move to buffer” permet de sauver l’état courant d’une 
texture dans une zone tampon et de rappeler ultérieurement cet état par la fonction 
“Buffers>Recall buffer”. Typiquement, cela permet de créer plusieurs textures puis de les 
mixer (voir fichier FAQ). Vous disposez de 3 zones tampon. 

 
 
Le panneau “Modules” 

 

Le panneau “Modules” est constitué de 3 colonnes. La première indique le nom du 
module. La seconde indique le module courant par une pastille beige. La troisième colonne 
spécifie si le module est actif ou pas. Une pastille rouge indique que le module est inactif. 

 
 
Le panneau "Current module blending parameters" 
 

Le panneau "Current module blending parameters" définit comment la couche courante et 
la couche résultat seront mélangées. 
 

 

Le panneau "Blending mode" 

 

Chaque canal (HSL ou RGB) peut avoir un paramètre différent de mélange qui est 
accessible par l’une des trois ComboBox (Red/Hue, Green/Saturation and 
Blue/Luminosity).  
 
La combobox "Mode" donne le choix entre les deux modes RGB et HSL. 
 
Le bouton "New branch" est un moyen rapide d'initialiser les paramètres des 3 canaux à la 
valeur "Current Layer". Cela veut dire que la couche courante ne sera pas mélangée à la 
couche résultat. C'est souvent le cas lorsqu'on veut créer différentes branches d'une 
texture puis les mélanger entre elles (voir fichier FAQ). 
 
Le bouton “Randomize” génére un choix aléatoire de paramètres de mélange pour les 3 
canaux. 



 
Le panneau "Transparency" 

 
Si la couleur de transparence est appliquée, tous les pixels de la couche courante 
correspondant à la couleur de transparence seront remplacés par la couche résultat, sans 
fonction de mélange. 
 
 
Le panneau "Result and current layers weight" 

 
Les ScrollBars “Result Layer” et “Current Layer” définissent l’opacité (le poids) de la 
couche courante et de la couche résultat. Si ces 2 valeurs sont initialisées à 0, le "Blending 
Mask" sera utilisé pour définir le poids respectif de ces 2 couches. 
 
Le bouton "Use blending mask" est un moyen rapide d'initialiser les 2 valeurs à 0. 
 
Le "blending mask" permet d'élargir considérablement les possibilités de mélange entre la 
couche courante et la couche résultat. Au lieu d'avoir un poids unique pour chaque pixel, 
le "blending mask" donne un poids différent à chacun des pixels. 
 
Pour utiliser le "Blending mask" il faut en principe suivre les étapes suivantes : 
 

- Commencer par créer une texture à base de un ou plusieurs modules 
- Puis, ajouter le module "Channels > Move to blending mask". Ce module permet 
de transférer l'un des canaux de la texture dans une zone de sauvegarde du 
"Blending Mask". 
- Ajouter ensuite quelques modules pour créer une "vraie" texture. Normalement, le 
premier de ces modules aura les 3 paramètres de mélanges à la valeur "Current 
Layer" pour éviter tout mélange avec la texture précedente qui aura servi de 
"Blending Mask". 
Ces modules peuvent maintenant reposer sur le "Blending Mask" pour effectuer le 
mélange. 

 
 
Le panneau "Randomize all modules and process" 

 
Le bouton “Rand. Blend.” génère un choix aléatoire de paramètres de mélange pour les 3 
canaux de l’ensemble des modules. 
 
Le bouton “Rand. Opacity” génère un choix aléatoire de paramètres d’opacité pour 
l’ensemble des modules. 
 
Le bouton “Rand. All” cumule la fonction des boutons “Rand. Blend.” et “Rand. Opacity”.   
 
Les 3 boutons “Rand. Blend.”, “Rand. Opacity” et “Rand. All” lancent automatiquement le 
calcul de la texture. 

 

 



La grille de paramètres des modules 
 
Une grille de paramètres apparaît à chaque création d'un nouveau module. La grille d'un module 
précédemment créé peut être rappelée en cliquant sur le nom du module. Seule la grille de 
paramètres du module courant est affichée à l'écran. 
 
Après le calcul d'une texture, la grille de paramètres courante disparaît pour laisser plus de place 
à la visualisation des images. Elle peut être rappelée en cliquant sur le nom du module courant. 
 
Certains modules qui disposent de nombreux paramètres (comme le module "Perlin Noise" ou le 
module "Blobs") disposent de 3 boutons permettant la génération aléatoire des paramètres ainsi 
que la sauvegarde et la restauration des paramètres du module. 
 



Aide et documentation 
 

Les modules et leurs paramètres associés sont documentés dans chacune des grilles de saisie. 
Cette documentation apparaît systématiquement en bas de la grille de saisie dans une boîte aux 
bordures bleu-marine. La documentation relative au module apparaît à la création du module ou 
lorsque l’on se positionne dessus dans la liste des modules. Pour obtenir une aide sur un 
paramètre en particulier, il suffit de cliquer sur le titre (label) de ce paramètre. 
 
En plus de cette documentation, certains modules disposent d’un ensemble de paramétrages 
prédéfinis (Built-in Preset). Il suffit de cliquer sur le nom de l’un de ces presets pour que les 
paramètres soient initialisés aux valeurs du “ Built in preset ”. Par ailleurs, ces mêmes modules 
disposent d’une fonction de génération aléatoire de paramètres. 

 


